G5 Club banner

1 - 11 of 11 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello all,

My friend and I attempted to install an aftermarket stereo system in his 2007 G5 today. We purchased the dash kit, wire harness (Scosche GM13SR), wiring kit, and head unit (Sony Xplod MEX-BT2700).

We got the stock head unit out and then connected all the wires from the harness to the head unit, and remote line and RCA to the amp. Once the amp was wired up (MTX Thunder 240 amp with MTX Thunder 4500 10" dual 4-ohm sub), the battery was connected and the receiver's CD motor started up a few times and then stopped. He turned the car on and we tried to turn on the deck but it would not turn on. We completely redid all the harness connections to ensure each wire had been matched up properly. Still, the deck would not turn on but the motor would still start up from time to time.

After much troubleshooting such as trying various connections, and searching this forum and google for help on this install, we decided to just put the stock head unit back in. Once that was in, it would not turn on either. And the key fob suddenly stopped working as well. We are completely stumped now . . . if there is something obvious we missed or if there are special parts/wires that need to be used for an aftermarket stereo in a 2007 G5, please let me know. Any help is appreciated!
 

·
Premium Member
Joined
·
1,602 Posts
Wow, I thought only my car was a dud when my keyfob quit working when I was putting my Pioneer deck in a 07 w/o onstar. I think what we did was held the lock and unlock button together and it started working, this was a long time ago though, its worth a shot.
 
1 - 11 of 11 Posts
Top