G5 Club banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all.

New here. Hoping to get some information to help fix the problem with my 2005 Pursuit (2.2L).

About 3-4 months ago the automatic transmission started acting funny. It would in second gear when accelerating from a stop instead of first. If I punched the gas to try to pass or speed up quickly it would slip.

I though that replacing the transmission would fix the problem. I picked up a used trans from a scrapper and had it installed. This didn't fix the problem so I though this trans was faulty. I then had another trans from a scrapper installed but it kept doing the same thing.

It seems to slip and not engage in the proper gear (especially under 20-30 mph) when accelerating. It doesn't get into 1st gear smoothly and instead slips. It feels like when you release the clutch in a manual car slowly when slamming the gas.

The most odd thing about it is that there seems to be a clicking sound coming from the shifter. It's almost as if there is a problem coming from there that is causing the problem, like the car is slipping into neutral. Sometimes the car seems to be fine, then other times it feels like it's slipping.

Could it be possible that the transmission isn't the problem? Is there a transmission shifter module or some sort of equivalent that could be causing the problem?

Any insight would be very helpful.

Thanks.
 

·
Registered
Joined
·
17,069 Posts
Yikes!! Two transmissions and still the same issue?

I would venture a guess that your ECM is programmed all wonky and not shifting properly.
 

·
Registered
Joined
·
1,679 Posts
ECM issues for sure or a problem with the throttle body..
 

·
Registered
Joined
·
1 Posts
I have a 2008 Pontiac g5, the automatic transmission will not shift into overdrive ( 4th gear) There are no warning lights that are on .... only 130000 kilometres .... please help
 
1 - 4 of 4 Posts
Top