G5 Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 · (Edited)
Hello, new to the community, just bought a manual 09 g5 base with about 129k.

Issues (that are probably connected?):

- Got a check engine light for p0102 first, replaced it with a generic MAF from partsgeek, still threw p0102. Had the wires checked by three different mechanics and they said it wasn't the wires or ECM. Replaced generic MAF with an OEM MAF sensor from ACDelco and now it's throwing both p0102 and p0452.

- Whenever I fill up (mostly while close to empty) the max amount the car will take is ~8gal while the tank should cap out at 13gal. With the tank filled with ~8gal, the gas gauge is one bar from full but drops FAST to about 3/4 tank after driving like ~20-25 miles (a days worth in the city)

- Occasionally when starting the car, the smell of gas enters the cabin for a couple seconds and will go away.

*Already replaced the gas cap, spark plugs, and ignition coils (aside from MAF sensors twice)
*Runs fine, no oil/ gas leaks as far as I can tell, no stalling (aside from my fault)

As I'm describing I'm thinking it's most likely a vacuum leak and the PCV valve may be the culprit but I'm not entirely sure. Any suggestions or insights?
Also, college student here so I'd have to do most repairs myself (any instruction/ links would be greatly appreciated)

Thanks!
 

·
Registered
'Gremlin' the 07 G5GT (913L)
Joined
·
140 Posts
Check your gas tank. Top Access is in the trunk behind the passenger seat, under the rug. Might not be sealed properly, maybe a hole, ect ect.
Check the fuel pipe into the tank and the lines underneath, corroded fuel lines are not that uncommon. If you don't see or smell anything, check with a full tank and the car running. Something almost certainly has to be open/loose somewhere if you smell gas
If its a vacuum line, you should be able to hear a hissing sound near the intake while the vehicle is running

As for the MAF, if the wiring and the sensor are good, I dont really know what to tell ya, especially if it's not running weird

For S&Gs, maybe try the EVAP Purge Solenoid?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Thanks for the info! Although I couldn't find the top access to the gas tank in the trunk, I suspect that you're right about the tank and lines. For the vacuum leak theory, I didn't hear any hissing noise either but I'm planning on giving it another listen.

Also jst bought a new evap purge solenoid so I'll replace that and see what happens
 
1 - 4 of 4 Posts
Top