G5 Club banner
1 - 10 of 10 Posts

·
Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
I've had the filter in for about a week now (also the new Reactive Exhaust since Thursday) and everything's been great, L/100km has gone down and everything running smooth but this morning i'm noticing that the car is consuming (according to that gas meter) almost double its normal usage for a normal trip from my home to work. Is this the MAF type issue that people were talking about before? or does anyone have any idea what the problem might be before I take the car into the dealership.
 

·
Registered
Joined
·
169 Posts
are u steping on it alot? when i got my gmpp air intake and i was steping on it alot and it sucks up gas like carzy. take it easy for a while and see what happens
 

·
Registered
Joined
·
6,037 Posts
Right out of the box on the disclaimer says clearly for the filter (as I just replaced my stock filter with a K&N) in BOLD and CAPITAL letters. THIS WILL NOT VOID YOUR MANUFACTURER WARRANTY! I trust K&N and feel confident with them so if there are any issues I'll be happy to bring it into the dealer as this is an approved aftermarket accessory and has be tested thoroughly.
 

·
Registered
Joined
·
52 Posts
Discussion Starter · #5 ·
i'm beginning to think something else happend to give me this issue. Something completely seperate from the K&N,

*side note, since I got the K&N and the new muffler I've noticed a large improvement in fuel economy up to this morning, Things however seem to have returned to normal.after about a 1/4 tank being guzzled away.
 

·
Registered
Joined
·
641 Posts
tank said:
I haven't had any issues with my K&N filter ... but I also just put it in yesterday...
I put mine back after that mess with my MAF, if it comes down to it again, I'll put the stock filter back and play dumb at the dealer.
 
1 - 10 of 10 Posts
Top