G5 Club banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
hey, I have a 2009 g5 gt that I bought a couple years ago everything was good till a few months back when I lost compression on cylinder number 2 due to a exhaust valve not closing properly so I replaced with a brand new head also while I was in there I went ahead and replaced the timing chain now it will start and idle ruff for a few seconds then die out unless I keep it around 3500 rpms I’ve replaced the coil packs and spark plugs and still no change just trying to get a few ideas thanks
 

·
Registered
2007 G5 GT in Fusion Orange. Lightly modded
Joined
·
58 Posts
So, if everything was fine (other than the stuck valve) before the chains were replaced, I'd start with the chains and see if they jumped a tooth. You may just be out of phase or are experiencing a "interference engine". When I replaced my cams, I was having a real hard time keeping all the dots lined up.

I'm sure you already know this, but here's a link to the Cloyes timing / balance shaft cabin replacement video on the Tubes of YOU....



If that doesn't cure the issue, you may have some damage to the cylinder, maybe the ECU is pissed off....hmmm 🤔
 

·
Super Moderator
Joined
·
604 Posts
Phasers being out would be my concern as well first. Additionally, I would change out the camshaft positions sensors (top of the engine to the left of the spark plugs). As for the stalling issues, it's possible you might have caused a vacuum leak when replacing the head. Make sure your hosing is on and tight. Or if they are old and you moved them out of the way, they could've cracked causing leaks as well.
 
1 - 4 of 4 Posts
Top