G5 Club banner
1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I bought a scosche speaker level converter to hook up my 2 MTX 12's and Kenwood Amp. The amp is powering on it looks like, the fan comes on at least. But then there is no sound from the subs. Any ideas on whats wrong? Maybe its not grounded?
 

·
Registered
Joined
·
25 Posts
you bought the converter bc you are keeping your stock head unit? I did the same make sure you have tapped into and ran the right wires to the converter also my converter had a switch betweeen different types of converting the signal make sure you have the one that is for amp output. hope this helps
 

·
Registered
Joined
·
101 Posts
fbmdeth said:
I bought a scosche speaker level converter to hook up my 2 MTX 12's and Kenwood Amp. The amp is powering on it looks like, the fan comes on at least. But then there is no sound from the subs. Any ideas on whats wrong? Maybe its not grounded?
Sounds like it may be a bad ground, I would also check your fuses.
 

·
Registered
Joined
·
547 Posts
Not sure how the G5 stereo is set up, but on my Grand Am and on my G6 I had to make sure to tap the converter in to the right speaker wires. The factory amp must have had a crossover and if you tap in to the wrong wires you will not get any sound from your subs.

Where did you hook up the wires that go to the Schosche converter (ie. did you hook them up to the stock rear speakers, did you hook them up to behind the stock head unit, etc)?
 

·
Registered
Joined
·
25 Posts
i dont think you have to ground the converter, i did not, if your amp is on then you have a good ground on it. the other thing is if you have the pioneer system/gt or 4 speaker system/base. if its base then its easy as that was what mine was, i got the same converter from walmart. just make sure your rear speakers are in the terminals A5-A8 and turn the switch on the left side to line out! then hook up your rcas.
 

·
Premium Member
Joined
·
1,602 Posts
if you have the pioneer system, try hooking it up to the stock sub wires, thats how mine is hooked up there hasnt been any problems yet it pounds loud and clear just ask denlou
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #7 ·
beezerfau which side did you hook yours up too?

I have the stock 4 speaker system, i hooked up them up on what would be the left side 6x9's if your looking into the trunk from behind the car.

Also beezerfau when you say a5-a8 did you hook up both 6x9's...and if its not a problem a picture would be greatly appreciated since i lost the manual for the converter.

Thanks for your help everyone.
 

·
Registered
Joined
·
25 Posts
fbmdeth said:
beezerfau which side did you hook yours up too?

I have the stock 4 speaker system, i hooked up them up on what would be the left side 6x9's if your looking into the trunk from behind the car.

Also beezerfau when you say a5-a8 did you hook up both 6x9's...and if its not a problem a picture would be greatly appreciated since i lost the manual for the converter.

Thanks for your help everyone.
hey dude, i hooked mine up to both the rear speaker s. i threw mine away too but here is what it should wire up to like mine

Left Rear (+): brown goes into slot A5
Left Rear (-): yellow goes into slot A6
Right Rear (+): dark blue goes into slot A7
Right Rear (-): light blue goes into slot A8

make sure u have the switch set to line out position. that should be it! also how are you running your remote turn off for your amp if u need help with that let me know.
__________________
 

·
PSD=PostSaturnDepression
Joined
·
826 Posts
Also, you will have to make sure that the gain on the L and R channels are turned up a little bit, if your gain is not up, even a little bit, it will not send out enough signal to hear it in your sub(s).

I did a how to for my Ion, which is practically identical for the G5. Check out the how to section, I will add it up now.

:)
 
1 - 9 of 9 Posts
Top