G5 Club banner
1 - 19 of 19 Posts

·
Registered
Joined
·
1,870 Posts
Discussion Starter · #1 ·
Okay, here's a challenge. I went to a dealership today to get the size of the stock crankshaft stabilizer pulley, and they couldn't help me at all. The reason is i found a lightweight pulley system for the cobalt/g5 engine, but it's listed in 2 sizes, 2.8" and 2.9". I do not want an underdrive or overdrive i want a lightweight. so if anyone can help me with what size the stock pulley is (gm P/T# 90537704 aka part # 427 in the GM Service and Repair Manual Diagram) that would be awesome. I don't want to order a part that will not do the job, and if the OEM parts are too small i can get one custom made. Please advise....

the pulley system link is
http://www.zzperformance.com/cobalt_ion/products1.php?id=613&catid=142

and another...

http://www.zzperformance.com/cobalt_ion/products1.php?id=446&catid=142
 

·
Registered
Joined
·
100 Posts
actually, both links are for supercharger pulley's for the LSJ's. GM's OEM pulley is ~ 3.34". I did find a lightweight crank pulley for these cars, but forgot where. I'd try Summit Racing. I think that was where it was. If not, just do a search on the internet using the Cobalt instead of G5.
 

·
Registered
Joined
·
1,870 Posts
Discussion Starter · #7 ·
i'm not looking for underdrive, i just want a lightweight pulley. Right now it dosen't matter i dropped a piston yesterday so i gotta get that fixed first... an i already got a flywheel an i am happy but i'm trying to get around 210 N/A still not quick enough. Just got clocked at 15.7 on the QM but i dropped a piston in the process..
 

·
Premium Member
Joined
·
10,371 Posts
by 'dropping a piston', what do you mean? theres lots of different definitions for that, all of them worse than the previous haha
 

·
Registered
Joined
·
1,870 Posts
Discussion Starter · #9 ·
halfway through the run 2 spark plugs misfired and stopped and i was running on only 2 pistons. "limp mode" kicked in and my track time SUCKED ASS!!! i had to get a new ignition, starter and plugs... nothing too serious but it still sucked... guess the stock ones aren't as great as everyone says lol! gonna try new times tonight and hope i don't blow anything again.... (fingers crossed)
 

·
Premium Member
Joined
·
10,371 Posts
haha could have been much worse. you might want to upgrade your whole ignition system then. them coils are not the best from what i hear
 

·
Registered
Joined
·
493 Posts
underground said:
halfway through the run 2 spark plugs misfired and stopped and i was running on only 2 pistons. "limp mode" kicked in and my track time SUCKED ASS!!! i had to get a new ignition, starter and plugs... nothing too serious but it still sucked... guess the stock ones aren't as great as everyone says lol! gonna try new times tonight and hope i don't blow anything again.... (fingers crossed)
my number 2 injector has never been the same since the head rebuild.
If you want that 210,you are gonna need a hpt tune amybe even cams.
 

·
PSD=PostSaturnDepression
Joined
·
826 Posts
Did you upgrade your valve train? or piston rods at least?
 

·
PSD=PostSaturnDepression
Joined
·
826 Posts
The 2.4l is.. but not 2.2, I wasn't sure if his was 2.2 or not.
 

·
PSD=PostSaturnDepression
Joined
·
826 Posts
*is on the ball* :mrgreen:
 
1 - 19 of 19 Posts
Top