G5 Club banner
21 - 22 of 22 Posts

·
Premium Member
Joined
·
12,885 Posts
I checked out the wires that go to the seat belt tension sensor, and they appeared to be okay. That night I decided to pull out the passenger seat so that I could gain better access to that sensor and the wiring harness, and I'm glad I did because this is what I found:
Wire Auto part


The seat harness must have got caught on something and the sharp bracket that the harness connects to sliced through a few of the wires. A few minutes with a soldering iron and shrink tubing fixed it.
Wire Electrical wiring Technology Electronic device Electronics accessory


The service air bag light went away with the next ignition cycle, and it hasn't come back on since. (I fixed it back in July.)
 

·
Registered
Joined
·
1 Posts
Its been awhile but a little update. My soldering didn't hold up for long and my light came back on a few weeks ago just in time for my car to be inspected to renew my plates! I ended up getting lucky and getting a new seat belt assembly off ebay for $55 and in black which seems hard to find for cheap. A little trick I found when replacing it to keep it from happening again is that the main issue is the wires are too short and get pulled apart causing the issue. I found when I replaced it that the harness for the wires is taped to a loom of wires, if you cut the tape holding the harness it gives it enough slack to move freely without tugging on the wires.
By chance do you know what orientation the wires go in is it black, blue ,red 🤔 starting from the bracket. Thx if you can help with that mine where all ripped out and can't tell which wire goes where.
 
21 - 22 of 22 Posts
Top